1. Home
  2. How To: ‘Move’ Planting Sites to Trees

How To: ‘Move’ Planting Sites to Trees

Do you have a Planting Site layer in TreePlotter™ ? If you want to move planting sites that have been planted into the trees layer, then these notes are for you. You may need to adjust the instructions to suit your own setup.

The process is to identify the sites with a tree in, export that to CSV and then use the Uploader tool to bring them into the trees layer. To avoid bringing the same planting site in next time, they should be archived or identified in some way.

Prerequisites:

  • Tutorial: Views
  • Tutorial: Uploader
  • Tutorial: Mass Updater

Steps:

  1. Filter for the planting sites that are now trees
    • Perhaps you need to look where the Status is Planted? Plus if you have such a field Moved to Trees tick box is NOT Yes
  1. Export the fields that you’ll need to use to upload them back into TreePlotter
    • Go to Data > Planting Sites and it would be helpful to create a new view so that it contains all the information you’ll need from the trees’ side
      • Essentially you want any fields that appear in both layers
      • As a minimum, you’ll need Latitude and Longitude, and ideally Common Name too
    • Export to CSV
      • Specify a filename or later rename the file so that it’s less than 30 characters and without any extra dots or special characters
      • If there are other data fields to pull through to the trees, you could take the opportunity to add the extra information into the spreadsheet
      • Note: If you apply the filter first and then create the view, the view will save the filter too, making it even easier for next time
  2. Upload the data into the tree layer
    • Hub > Data Tools > Uploader
      • Ensure you choose the Trees layer to upload into
      • Specify the long and lat columns
      • Ensure there are red circles
      • Crosswalk the data in
        • No need to bring in latitude or longitude, these will be automatically generated
      • Import features to the map
      • Check your new records are in place
  3. Mass update the selected planting sites so they aren’t brought in again next time
    • As long as you haven’t refreshed, you should still be filtered for the planting sites you exported
    • Data Tools > Mass Updater
      • Do you want to still see them on the planting sites layer?
      • Either mark Moved to Trees as Yes and/or archive the planting sites so they aren’t on the map any longer
  • You may like to Save the Routine so that it’s easier next time.

Known limitations:

  • You need to be logged in as a user with the Admin role in order for the menu options to appear
  • You can’t upload photos.

Potential next steps:

  • How To: Mass Update
Updated on June 26, 2024